Saturday, December 28, 2013

foomatic is moving into cups-filters

Part of the printing packages on Gentoo are very similar to, err, well, a dumpster on a hot summer afternoon. Nobody really wants to lift the lid and look inside, and beware of poking around in it... version numbers starting with 2007 and self-generated distfiles that noone knows how to regenerate. Yes I'm trying but so far my insights are limited.
What news is happening? The foomatic filters, an awesome printer driver system, originally supported not just CUPS but also LPRng, LPD, and many other prehistoric printing systems. Turns out, every backend except cups is now unmaintained. As a result, after a Google summer of code project, the actual filter binary is now upstream moving into cups-filters, to have a more active development and be perfectly integrated into the CUPS printing system. (Yes this means foomatic support for LPRng will not see further updates and may have to go away one day in the future due to bitrot.) For Gentoo this means that newer versions of net-print/cups-filters cannot be installed together with net-print/foomatic-filters but replace that package.
As a result we get to today's call for testers, preferably ~arch users: If you feel adventurous and if you are using foomatic-filters together with cups, please keyword newest cups-filters, remove foomatic-filters from your world file, and upgrade:
echo '=net-print/cups-filters-1* **' > /etc/portage/package.keywords/cupsfilters
emerge --deselect net-print/foomatic-filters
emerge -uDNav world
If this leads to blockers with one of the following packages, you might want to upgrade that to newest ~arch or re-emerge it first:  net-print/foo2zjs, net-print/foomatic-db-engine, net-print/foomatic-filters-ppds, net-print/hplip, net-print/pnm2ppa
Then, test if your printers still work! Any feedback is appreciated, either on a tracking bug or here in the comments section.

Sunday, December 8, 2013

LibreOffice KDE integration

I was this close to just masking the LibreOffice KDE integration in Gentoo and let it be done with that. Recently some really ugly bugs in the glue code crept up (crashes in the file dialog and in drag-n-drop), impacting productivity a lot... Asking around I heard that the KDE/Qt integration of LibreOffice was basically unmaintained and bitrotting.
Luckily someone stepped up and started bugfixing, and patches have made their way into the LibreOffice git master branch (and partially also into libreoffice-4.2). I have prepared a backport for the two bugs mentioned above; I'm flying blind and this is completely untested, but feedback on the bug reports would be very welcome! If you want to try (note, this affects only LibreOffice with USE=kde), keyword
=app-office/libreoffice- **
somewhere in /etc/portage/package.keywords, start the update, and get some fish for your penguins; they will be busy for a while... :)